I have tried using the webapp in the latest versio...
# general
I have tried using the webapp in the latest version
When navigating to
I get page not found. Is there an alternative download that includes the webapp?
Hi Craig, WireMock standalone (and OSS generally) is headless - configured via programmatic, REST and file based APIs. There’s a small UI for recording under
I appreciate what you are saying, but that interface was REALLY useful. I will learn to adapt.
There was never a UI there in the standard builds. Perhaps you were using a custom build previously?
If you like having a UI, have you tried WireMock Cloud?
? (Although this is just the admin API, not your own custom mappings)
https://github.com/holomekc/wiremock -> @Craig Is this the WireMock you were using before?
👍 1
I was using this UI. Which was included in
which I am pretty sure I downloaded from somewhere "official".
Copy code
That’s not a version number we’d have used, so I’m guessing this is a fork. I don’t recognise the UI either.
is a version that the holomekc fork uses -> https://github.com/holomekc/wiremock/releases/tag/… and the UI looks the same, so I’d guess it’s that repo’s fork
🎯 1
@Tom / @Oleg Nenashev have y’all reached out to
about bringing their project underneath the greater WM banner (….or does it end up competing with WireMock Cloud)?
The problem with https://github.com/holomekc/wiremock is that it is a (hard)-fork of WireMock based on the old version, and hence it could not be included without major rework
That's the one, thanks, did not realize it was a fork. I do like the GUI, pity it's an older version.
It was recently updated to WireMock 3, though it is not that old. At the same time the concern about being a hard fork remains, for the moment I would recommend reaching out to the maintainer, for example using a GitHub issue